Internal Server problem
Incident Report for MYM
Resolved
This incident has been resolved.
Posted Feb 04, 2022 - 19:02 CET
Investigating
We're facing some technical issues with our servers right now. We are working on it, and hope to get the servers back online asap.
Posted Feb 04, 2022 - 17:48 CET
This incident affected: MYM for fans, MYM for creators, and MYM for ambassadors.