(Creators) Push history: problem with the recipient fans counter
Incident Report for MYM
Resolved
This incident has been resolved.
Posted Oct 14, 2021 - 20:49 CEST
Identified
The issue has been identified and a fix is being implemented
Posted Sep 20, 2021 - 15:53 CEST
This incident affected: MYM for creators.