We are facing some technical problems playing videos on Android and iOS
Incident Report for MYM
Resolved
This incident has been resolved.
Posted Sep 21, 2021 - 14:25 CEST
Identified
The player is unable to move forward and backward. The issue has been identified and a fix is being implemented.
Posted Sep 20, 2021 - 16:09 CEST
This incident affected: MYM for fans and MYM for creators.