We are having some video playback issues
Incident Report for MYM
Resolved
This incident has been resolved.
Posted Sep 21, 2021 - 14:42 CEST
Identified
We are facing trouble playing some videos. The bug is identified we are proceeding with the fix
Posted Sep 20, 2021 - 11:05 CEST
This incident affected: MYM for fans and MYM for creators.