We have an issue with Creators' subscribers counter, showing a lower value than it really is
Incident Report for MYM
Resolved
This incident has been resolved.
Posted Sep 01, 2021 - 10:48 CEST
Update
This is just a display issue, no subscribers have been lost. We are working on it.
Posted Aug 27, 2021 - 14:13 CEST
Investigating
We are currently investigating this issue.
Posted Aug 27, 2021 - 14:12 CEST
This incident affected: MYM for creators.