The site is experiencing technical difficulties
Incident Report for MYM
Resolved
The incident is resolved
Posted Mar 24, 2023 - 21:46 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2023 - 18:17 CET
Investigating
We are currently investigating this issue.
Posted Mar 24, 2023 - 18:14 CET
This incident affected: MYM for fans, MYM for creators, and MYM for ambassadors.